首页 » ORACLE » 64位linux安装ORACLE10G报i386/libawt.so: libXp.so.6: cannot open shared object file

64位linux安装ORACLE10G报i386/libawt.so: libXp.so.6: cannot open shared object file

昨天在给一台新机器装oracle,系统是centos 5.2 x64,数据库 库是oracle 10g x64,按装官方文档把包也检查了一下,但在.runrunInstaller时,报错Exception in thread “main” java.lang.UnsatisfiedLinkError: /tmp/OraInstall2007-12-21_10-40-21PM/jre/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1560)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1477)
at java.lang.Runtime.loadLibrary0(Runtime.java:788)
at java.lang.System.loadLibrary(System.java:834)
at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)
at java.security.AccessController.doPrivileged(Native Method)
at sun.awt.NativeLibLoader.loadLibraries(NativeLibLoader.java:38)
at sun.awt.DebugHelper.<clinit>(DebugHelper.java:29)
at java.awt.Component.<clinit>(Component.java:506)
at oracle.sysman.oii.oiic.OiicInstaller.main(OiicInstaller.java:593)

记的以前在redhat el 5  x32上装时也有遇到这个问题,安装了libXp这个包就没问题了,然后去系统盘的 去找这个包,发现一个i386 及32位程序包,还有一个x64位,当时毫不犹豫装了x64位的,但还是提示上面的错误,怪了,难道要装那个i386的?试一把,英明的决策,问题没有了。

后绪篇

安装10.2.0.1后又安装了10.2.0.4的升级包,升级并未真正完成,要升级数据字典,编译无效对象,启动时一定要startup upgrade;

SQL>@?/rdbms/admin/catupgrd.sql 升级数据字典,?为$ORACLE_HOME,未配置变量需指明全路径

SQL>@?/rdbms/admin/utlrp.sql 编译无效对象

记的 以前我有一篇做的直接copy datafile  做的数据库迁移也是那么做的,最后在装个rlwrap ,设置自动启动,大功告成!

打赏

目前这篇文章有3条评论(Rss)评论关闭。

  1. Phyliss Dimascio | #1
    2011-12-21 at 03:48

    I love your writing style really enjoying this web site .

  2. Arry | #2
    2011-09-03 at 13:12

    Now that’s sbulte! Great to hear from you.

    • Denim | #3
      2011-11-11 at 08:28

      Shiver me tibmres, them’s some great information.