首页 » Goldengate, ORACLE 12C » 注意: GoldenGate12.2不支持Oracle RDBMS 12.2 error OGG-06535

注意: GoldenGate12.2不支持Oracle RDBMS 12.2 error OGG-06535

ORACLE RDBMS 12.2 在201703发布以后,也行新特性确实吸引了很多追求新技术的爱好者, 但是这次更新有些大,如果计划数据库升级到12.2 一定要充分考虑当前的软件是否支持ORACLE 12.2, 前不久一个客户刚上线的一套12C R2    3节点RAC就因为开始未考虑到OGG的版本支持,不得不面临着数据库再降级的问题。

OGG Error log

2017-04-14 10:16:11  INFO    OGG-00987  Oracle GoldenGate Command Interpreter for Oracle:  GGSCI command (oracle): REGISTER EXTRACT eora DATABASE CONTAINER(orcl).
2017-04-14 10:16:11  ERROR   OGG-06535  Oracle GoldenGate Command Interpreter for Oracle:  Extract does not support the database compatible setting 12.2.0.

也许是ORACLE的产品线太多,有线产品不能同步的发布, 但是像OGG 这种和数据库密切的产品,个人觉的确实不该出现这样的局面。

从ORACLE MOS Note ID 2252693.1 可以确认,在写篇日志时,确实已发布最新版的OGG 12.2还不支持ORACLE RDBMS 12.2,  OGG 的版本是向前兼容的, 按ORACLE的计划会在OGG 12.3版本解决,支持从ORACLE 12.2 extract,(注意这里的OGG 12.3 不是OGG for Bigdata 12.3) , 并且会在2017年的6、7月份发布OGG 12.3, 并未说是否是所有平台, 已支持的平台认证请看这里

OGG currently doesn't support 12c R2 db. It will be supported in OGG v12.3 which is currently targeted for release in June/July 2017.

OGG 和 ORACLE RDBMS版本 anbob.com版本建议如下:

GoldenGate 12.3 supports Oracle ≥ 12.2.0.1
GoldenGate 12.2 supports Oracle ≥ 11.2.0.1
GoldenGate 12.1 supports Oracle ≥ 11.1.0.6
GoldenGate 11.2 supports Oracle ≥ 10.2.0.4
For earlier database versions (8i (DML only), 9i-11.1) use GoldenGate 10.4

如果你的当前的数据库环境有使用OGG 产品,切记在确认OGG 12.3发布后,再考虑升级RDBMS 12C R2.

转载 请注明出处 ANBOB.COM ,   微信公众号: ANBOB手记

打赏

,

对不起,这篇文章暂时关闭评论。